5.3.6.0

Bug Fixes

Set Status Trigger Action Causes Incorrect Status for Dependent Children

#8552

This bug was occurring when you used the Set Status Trigger Action to make Standard Page assets Live as soon as their workflow process was finished and the asset was in a status of Safe Edit Approved To Go Live.

Often a trigger like this was required to set up so that assets that were approved to go live after a workflow process, were made Live instantly instead of having to manually set the status to Live.

Because of this bug, the trigger needed to be configured to set a Future Status of Live instead, due to the Trigger firing the Live status on all dependent assets before they could go into a status of Safe Edit Approved To Go Live first.

With this fix, you can now successfully set up an automatic workflow go-live trigger using the following settings:

  • Trigger Event: Status Changed
  • Trigger Condition: Asset Status - Asset has a current status of Safe Edit Approved To Go Live or Approved To Go Live
    (probably also want other conditions in here, such as asset is of type Page)
  • Trigger Event: Set Status - Set status to Live

Other Bug Fixes

  • #8345 - Update 'filter' field in getGoogleAnalyticsStatistics to follow Google Analytics API standard
  • #8552 - Trigger event "Status Change" and Trigger Action "Set Status" with Workflow makes the depended children status async
  • #8578 - link_target_* keyword returns site asset when it shouldn't
  • #8579 - replace_keywords fails when subsequent modifier contains spaces
  • #8670 - Remove content template selection option on type format of Paint layouts as it's not supported yet
  • #8839 - Decision Tree without URL can't progress past first question
  • #9032 - Images that are pasted/dragged in and have the low res preview, should not have re-size drag handles available
  • #9082 - Invalid characters in raw HTML can break content when switched to a WYSIWYG editor
  • #9130 - On the Edit+ Workflow screen, in the Workflow Summary section, the Group Logic td of each Step needs to be wider.
  • #9174 - globals_site_assetid returns incorrect value when trigger activated by Edit+
  • #9180 - Asset listing "Customise No Results Bodycopy" Dissapearing
  • #9251 - Keyword not being added in Raw HTML Div when not focused
  • #9302 - "Use the link value" when creating a link is limited to 20 characters, but not limited after commit
  • #9316 - Using "asset_contents" keyword in the metadata for Redirect Page will break the asset's metadata screen
  • #9387 - When committing Settings screen of asset with no created_userid, current user is set as created_userid
  • #9519 - Snippet dropdown broken in IE in Edit+
  • #9673 - Design areas with cache="yes" render different whitespace with _nocache
  • #9702 - Cloning SAML Account Manager is incomplete
  • #9712 - Bug downloading csv file on Edit+
  • #9769 - Unsaved changes warning doesn't trigger after WYSIWYG edit
  • #9896 - Content Container with Template applied is editable when locks aren't held
  • #9929 - Export/Import XML doesn't handle paint layout conditional keyword ids
  • #9935 - TRIG0006 errors with valid triggers cloning assets
  • #10010 - Setting a Dynamic Create Location in an Asset Builder, without setting the Root Node with throw php error when previewing asset
  • #10023 - Append Query String option on REST assets with multiple URLs only uses first URL
  • #10027 - CSV Data Source missing Web Paths screen
  • #10032 - File folders should only compile sub file assets that are matching it's safe edit status state
  • #10048 - .m4v video files are displayed as text in Chrome and Safari - no mime type defined
  • #10087 - Using an invalid keyword as the Set Value for the Replacement Root Node in listings will show Fatal errors on the front end
  • #10116 - Global and asset keywords don't get evaluated within the Page Contents container of Paint Layouts
  • #10245 - Update note in Additional Conditional Delivery Fee section of the Checkout page Asset
  • #10263 - Creating triggers outside the Trigger Manager results in Matrix Warnings
  • #10329 - "Insert keyword" select field is no stacked above textarea in classic raw html editor
  • #10339 - Send Email Form Submission Action throws many alerts if Classic Editor is enabled in Admin
  • #10371 - Minimum/Maximum Depth/Height values on Asset Listing Page asset can be null, and won't save as zero
  • #10375 - Deleting Multiple assets from the Asset Tree that exist in trash already with throw HIPO errors
  • #10390 - When Previewing an asset in Admin, changing either the Preview URL or the Context in the Preview options causes the Preview to open in a new window.
  • #10401 - When Submitting an Online Poll Question when you are in a non Default context in Admin, Php Errors are shown and Poll option labels are deleted
  • #10402 - Asset with nested Remote Content display incorrect with %begin_asset_contents^keyword_modifier%
  • #10414 - Using mysource_files/ when referencing git files in css and scss assets removes the path
  • #10425 - Setting future status in Edit+ throws JS error
  • #10438 - Multiple HIPO confirmation screens do not wrap text for asset names.
  • #10442 - Remove OEM FB checks from system_check.php
  • #10445 - Keyword "event_duration_ical" should not use months or years in its result
  • #10452 - Asset map loses its target indicator in certain situations
  • #10453 - Multiline headings in WYSIWYGs overlap
  • #10454 - When previewing pages that have a URL on another domain it should open with _nocache
  • #10462 - Update Twitter Status trigger action fails to authenticate
  • #10463 - Trigger action "Redirect to URL" exiting the process if the redirect URL set is empty
  • #10483 - Problem with required attribute on Asset Builder
  • #10484 - setContentOfEditableFileAsset JS API function always returns error
  • #10490 - User restrictions bug with Type 2 links
  • #10505 - Simple Edit conditional Metadata field not being updated/rewritten on export/import
  • #10516 - Squiz Suite Manager if moved from the Web Services Folder it can not be moved back in.
  • #10551 - Grammatical error on Workflow screen in admin mode ('.Add New Workflow Stream)
  • #10559 - Backport #10070 (File chunked reads for partial content) to 5.3
  • #10562 - Custom form with file upload question type will not be submitted if file name contains special characters.
  • #10563 - Matrix Metadata SOAP Service function GetMetadataFieldsDetailOfSchema() not working
  • #10570 - Remove Template on content container should remove the metadata schemas on containers too
  • #10579 - Trigger action Set Metadata Date Value hours and minutes fields are backwards
  • #10591 - If Commit button text is empty, show default value instead
  • #10601 - Safe editing a file folder and editing a safe edited file under it causes it to lose it's __data URL
  • #10605 - Nested sub section in  custom form is not submitted when section is set to safe edit mode.
  • #10626 - System Configuration - Active Locks - For Form Contents Asset, Matrix is showing the Asset type as 'Form Email
  • #10628 - Asset tag line is missing for form questions

The Latest

Releases

Date 5.4 5.3
14 Nov 20175.4.3.1
23 Oct 20175.4.3.0
19 Sep 20175.4.2.3
28 Aug 20175.4.2.25.3.7.2
07 Aug 20175.4.2.15.3.7.1
03 Jul 20175.4.2.05.3.7.0
26 Apr 20175.4.1.35.3.6.1
13 Mar 20175.4.1.2
07 Mar 20175.4.1.1

Let Us Know What You Think

Let us know if you spot any errors or if you have any ideas on how we can improve the Matrix Community Website.

Contact Squiz for Demo

Let us show you the true power of Squiz Matrix by giving you a personalised demonstration.