5.2.12.0

This is the last release in the 5.2 branch.

Bug Fixes

  • #10187 - Trigger REST Response Condition saves unusable conditions
  • #10197 - Asset Builder Page Create Location Rules always pass
  • #10195 - Asset Listing page can't sort by Short Name when grouping by letter
  • #10114 - Filter Front End User Input should filter for metadata values set by JS API
  • #10186 - local user account gets locked unexpectedly
  • #10182 - Modifying a question, increments the asset version number twice.
  • #9768 - Spelling mistake - seperated
  • #9785 - The Viper inline toolbar sits above the main toolbar in both Admin and Edit+
  • #10167 - RSS Assets send the wrong Content-Type header type
  • #10117 - DB Data Source has various issues when changing the Database Type
  • #10163 - Unable to clone the design assets.
  • #8773 - Product assets placed in Safe Edit are showing changes on the frontend.
  • #10153 - Edit+ Editor (WYSIWYG) will display "area contains no content" when the only content is "bbb"
  • #9443 - XML Datasource Asset needs to set a timeout when making curl request to the remote XML feed url
  • #9497 - Workflow Schema Apply or Delete to an asset is not logged
  • #10069 - Files served by Matrix are buffered unnecessarily
  • #9915 - comments metadata of mp3 file can not be extracted/read if getID3 lib version 1.9 used
  • #9933 - asset.workflow.userlog internal message not sent correctly for Workflow Bundle and SOAP Workflow Service
  • #9863 - add fonts mime types to Matrix's in-built mime list
  • #10084 - Duplicate file attachments will be send in email with the latest version of Mail_mime class.
  • #10142 - Can not send Email to LDAP users under a Matrix User group
  • #9966 - Paint layout and design ID keywords print incorrect values when using them in globals:XXXX or type formats of listings
  • #9914 - Globals attribute keywords don't work on redirect pages and link assets when pointing to an asset ID
  • #9483 - Changing Text in a table to a list removed the <td>
  • #8887 - Create Link Trigger Does not work for Target asset set to metadata keyword
  • #10111 - Couple of fixes for Product Assets
  • #10090 - Links report incorrectly reports links within pre tags
  • #9942 - Performance issue is Password Reset Page when accessing password reset page link.
  • #7752 - Remove links trigger action has confusing notes and labels and selecting 1 as root node value doesn't work
  • #8852 - Edit+ - when putting an asset into workflow, workflow message is shown then hidden
  • #10028 - Cloning a design asset failing
  • #9782 - "Rest Response Received" Trigger event not triggered for Form Submission Action "Call Rest Resource"
  • #9832 - Public user missing Details screen field names
  • #9948 - Keyword modifiers not working on
  • #9824 - Matrix loses extensions on long web paths
  • #9447 - Add URL trigger does not save the select context.
  • #9922 - Cloning assets in Edit+ for users with write access only throws errors, breaks screen
  • #9007 - Any remap value is allowed to be entered and when done, can't be deleted
  • #9978 - Sharepoint connector can not connect to NTLM authentication Sharepoint
  • #9958 - Issues running system_update_lookups.php in Oracle system
  • #9972 - Trigger action "Create Design Customisation" displaying incorrect "new customisation name" setting
  • #8656 - setMetadata and setMetadataAllFields incorrectly reports metadata fields as updated when they aren't
  • #9931 - Remove PHP WDDX requirement
  • #9947 - Cache issue when a listing page is nested multiple times with dynamic parameter set
  • #9039 - and for multl-select fields not correct
  • #9900 - export_to_xml.php script better error display when it fails to export file due to permission problem
  • #9728 - Metadata section notes in Edit+ shows 'undefined' strings
  • #9876 - Container Template Edit layout applied, Acquire lock, Commit button don't work
  • #9789 - Export and Import XML tools remove empty lines on content containers
  • #9767 - Permissions that are not selected for Cascade are removed on Clone
  • #9813 - Using 8034 as metadata field default value will throw fatal error when trying to create new asset when cascading the metadata schema
  • #9644 - Workflow approval comment box appearing when it should not in Edit+.
  • #9793 - Removing all linked JS or CSS files from a file folder breaks it
  • #9502 - When layout is set for a specific asset in layout manager, the assetid should be used as notice links instead of saving it as attribute value.

Let Us Know What You Think

Let us know if you spot any errors or if you have any ideas on how we can improve the Matrix Community Website.

Contact Squiz for Demo

Let us show you the true power of Squiz Matrix by giving you a personalised demonstration.